Snap, crackle & pop exhaust - Honda Fury Forums: Honda Chopper Forum
 
LinkBack Thread Tools Display Modes
post #1 of 8 (permalink) Old 12-04-2012, 04:10 AM Thread Starter
Senior Member
 
Join Date: Nov 2012
Location: Sydney Australia
Posts: 221
Snap, crackle & pop exhaust

I have picked up a 2010 fury which has cobra sweep pipes on it. Sound is great, but when I decelerate, the bike suffers from the rice bubble sound of snap, crackle & pop, which is damn annoying.

It also has a replacement air filter with s&s super on it. I have read threads about fitting various units which will eliminate the problem. I rang the previous owner, who thought that something had been fitted.

Never had this problem prior, as my previous rides were either crotch rockets or a hd bad boy springer.

So my questions are, where would it be mounted & if there is not one, what would be the recommendations?

Thanks
Austones

From the land down under
Austones is offline  
Sponsored Links
Advertisement
 
post #2 of 8 (permalink) Old 12-04-2012, 05:06 AM
Senior Member
 
DaveRed's Avatar
 
Join Date: Jun 2012
Location: Barrie/Ont
Posts: 5,415
If u search Pair valve removal , it will explain Ur issue , and I'm sure more ppl will advise , after removing it , I only get an occasional pop after hard accel / decel.


Sent from my iPhone using Motorcycle.com App
DaveRed is online now  
post #3 of 8 (permalink) Old 12-04-2012, 09:25 AM
Lifetime Member
 
X_KIOWA_X's Avatar
 
Join Date: Apr 2010
Location: Panhandle of FL
Posts: 4,683
Actually you could have a couple of different problems, exhaust leak, or it could be you need to remove the pair valve, and if you don't have a fuel controller you might want to look into getting one since you have an aftermarket exhaust and aftermarket air intake, those are my suggestions.


Mods: Morton Inferno Exhaust, Painted Engine, PowderCoated Rims, Kury Skull Shift and Brake Pegs, Kury Skull Foot Pegs, Kury Passenger Pegs, Danny Gray Seat, Ginz Sissybar, STG Fork Covers, Freedom T-Mod, Irate Skull Grill, MFR +3 Forwards
X_KIOWA_X is online now  
post #4 of 8 (permalink) Old 12-04-2012, 10:13 AM
Senior Member
 
ikya's Avatar
 
Join Date: Jan 2011
Location: westminster,ca.
Posts: 142
The very first thing you should check is the bolts at the heads on the exhaust pipes. A small leak there will definitely cause your popping.

2010 Black and Chrome and Chrome and Chrome........ What else?
ikya is offline  
post #5 of 8 (permalink) Old 12-04-2012, 12:59 PM
Senior Member
 
Furious Brit's Avatar
 
Join Date: Jan 2012
Location: south coast UK
Posts: 1,550
Quote:
Originally Posted by X_KIOWA_X View Post
Actually you could have a couple of different problems, exhaust leak, or it could be you need to remove the pair valve, and if you don't have a fuel controller you might want to look into getting one since you have an aftermarket exhaust and aftermarket air intake, those are my suggestions.
What X_KIOWA_X says, Plus look here VTX-Parts 1300 & 1800 Honda VTX Custom Motorcycle Parts, Pair Valve Covers, Radiator Grill Covers, Exhaust System Covers, Reed Valve Covers, Polished Stainless Steel, Polished Aluminum, Chrome

MELIORA SPERO
Furious Brit is offline  
post #6 of 8 (permalink) Old 12-04-2012, 01:34 PM
Senior Member
 
Join Date: Aug 2012
Posts: 332
Be sure you get the plates with dimples.
Wildman is offline  
post #7 of 8 (permalink) Old 12-04-2012, 02:13 PM
Senior Member
 
DaveRed's Avatar
 
Join Date: Jun 2012
Location: Barrie/Ont
Posts: 5,415
You can also tap the cover for 7/16 or 10mm as shown , a member posted these pics , Click image for larger version

Name:	ImageUploadedByMotorcycle1354648227.742958.jpg
Views:	291
Size:	34.1 KB
ID:	15598
Click image for larger version

Name:	ImageUploadedByMotorcycle1354648243.810310.jpg
Views:	291
Size:	35.4 KB
ID:	15599
Click image for larger version

Name:	ImageUploadedByMotorcycle1354648261.922955.jpg
Views:	264
Size:	33.0 KB
ID:	15600
This is how I blocked mine , also block the exit from Ur air cleaner , I cut the plastic back , tapped and blocked with 8mm if I remember correctly.


Sent from my iPhone using Motorcycle.com App
DaveRed is online now  
post #8 of 8 (permalink) Old 12-04-2012, 02:28 PM Thread Starter
Senior Member
 
Join Date: Nov 2012
Location: Sydney Australia
Posts: 221
Thanks, I will have a look this weekend & see what if anything has been done

Cheers
Austones

From the land down under
Austones is offline  
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Honda Fury Forums: Honda Chopper Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in









Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome