Speedometer problems - Honda Fury Forums: Honda Chopper Forum
 
LinkBack Thread Tools Display Modes
post #1 of 5 (permalink) Old 06-14-2013, 06:34 AM Thread Starter
Member
 
Sthrnflvr89's Avatar
 
Join Date: Sep 2012
Posts: 93
Speedometer problems

My fury is a 2012 with only 3000 miles on it now and my speedometer keeps going in and out it'll work every now and then... Is anyone else having this problem? Don't know if this is electrical and if the sensor or gear is in the transmission then it would either work or not work so that's why I'm going with electrical issue?


Sent from Motorcycle.com Free App
Sthrnflvr89 is offline  
Sponsored Links
Advertisement
 
post #2 of 5 (permalink) Old 06-14-2013, 07:10 AM
Senior Member
 
DaveRed's Avatar
 
Join Date: Jun 2012
Location: Barrie/Ont
Posts: 5,415
Check the multi pin connector that attaches to the speedo is secure .


Sent from Motorcycle.com App
DaveRed is online now  
post #3 of 5 (permalink) Old 06-14-2013, 09:22 AM
Senior Member
 
Join Date: May 2010
Location: HOUSTON TEXAS
Posts: 575
Check connections at instrument cluster and also check connnections inside your head lamp assembly. Thats were most of your electrical connectors are at.
ALEYRAY is offline  
post #4 of 5 (permalink) Old 06-14-2013, 11:45 AM
Senior Member
 
ctc6698's Avatar
 
Join Date: Sep 2010
Location: Kings Mtn, NC
Posts: 788
There's a mini fuse in the fuse box behind right side cover. Maybe loose or something. From experience, I know when it blows, speedo doesnt work at all. Just thinking out loud.

March 2012 Fury Of the Month
July 2013 V-Twin Magazine
ctc6698 is offline  
post #5 of 5 (permalink) Old 06-14-2013, 07:25 PM Thread Starter
Member
 
Sthrnflvr89's Avatar
 
Join Date: Sep 2012
Posts: 93
Yea I did replace my headlight with an hid and got everything stuffed in pretty tight in there could be causing some problems but I noticed today riding that at one point it was reading 20 then skipped to 50 could be slipping on the rod


Sent from Motorcycle.com Free App
Sthrnflvr89 is offline  
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Honda Fury Forums: Honda Chopper Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in









Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome