New Lizard Lights LED's installed - Honda Fury Forums: Honda Chopper Forum
 
LinkBack Thread Tools Display Modes
post #1 of 10 (permalink) Old 12-03-2012, 08:51 PM Thread Starter
Senior Member
 
jeff3254's Avatar
 
Join Date: Aug 2012
Location: Covington, GA
Posts: 414
Talking New Lizard Lights LED's installed

Finally got my LED's installed to compliment the new sumo-x kit......& the new wheels.......... last pic,,,, had to brag on that new rear tire.... she looks soooooo much better with it on there.
Attached Thumbnails
Click image for larger version

Name:	LED'S  1.jpg
Views:	822
Size:	55.6 KB
ID:	15590   Click image for larger version

Name:	LED's 2.jpg
Views:	931
Size:	62.1 KB
ID:	15591   Click image for larger version

Name:	LED's 3.jpg
Views:	454
Size:	62.9 KB
ID:	15592   Click image for larger version

Name:	LED's 4.jpg
Views:	444
Size:	47.7 KB
ID:	15593   Click image for larger version

Name:	Led's 5.jpg
Views:	436
Size:	67.6 KB
ID:	15594  


Jeffro
jeff3254 is offline  
Sponsored Links
Advertisement
 
post #2 of 10 (permalink) Old 12-04-2012, 10:33 AM
Senior Member
 
DaveRed's Avatar
 
Join Date: Jun 2012
Location: Barrie/Ont
Posts: 5,331
The only fat ass that I'm into , lol
Excellent look


Sent from my iPhone using Motorcycle.com App
DaveRed is online now  
post #3 of 10 (permalink) Old 12-04-2012, 11:02 AM Thread Starter
Senior Member
 
jeff3254's Avatar
 
Join Date: Aug 2012
Location: Covington, GA
Posts: 414
hahahaa awwwwwwwwwww fat asses need lovin too..............

besides,,,,, my motto chubby girls are chubby on the inside too........ hahaha
& they try harder cause they want some repeat business haha

Jeffro
jeff3254 is offline  
post #4 of 10 (permalink) Old 12-04-2012, 11:47 AM
Senior Member
 
Join Date: May 2010
Location: HOUSTON TEXAS
Posts: 575
Could you measure the gap between your rear fender and your tire. It seems mine is to close and im rubbing. Maybe two measurements one from the rear tip to tire and side of fender to tire. Thanks that will help me a lot.
ALEYRAY is offline  
post #5 of 10 (permalink) Old 12-04-2012, 01:27 PM Thread Starter
Senior Member
 
jeff3254's Avatar
 
Join Date: Aug 2012
Location: Covington, GA
Posts: 414
rear tip to tire is 1 1/2" side of tire to fender is 3/4" both sides i still have stock spring....... havent changed any of that

hope that helped

Jeffro
jeff3254 is offline  
post #6 of 10 (permalink) Old 12-04-2012, 06:46 PM
Member
 
CurtisFury's Avatar
 
Join Date: Apr 2012
Location: Nashville TN
Posts: 89
Nice! Looks great


Sent from my iPhone using Motorcycle.com Free App
CurtisFury is offline  
post #7 of 10 (permalink) Old 12-04-2012, 06:48 PM Thread Starter
Senior Member
 
jeff3254's Avatar
 
Join Date: Aug 2012
Location: Covington, GA
Posts: 414
thx
looking for a LED taillight mod then comes the paint

Jeffro
jeff3254 is offline  
post #8 of 10 (permalink) Old 12-05-2012, 12:18 PM
Senior Member
 
Join Date: May 2010
Location: HOUSTON TEXAS
Posts: 575
Thanks. I have more gap than that and i still rub once in a while.
5/10 and weigh 175 lbs.
ALEYRAY is offline  
post #9 of 10 (permalink) Old 12-05-2012, 12:23 PM
Senior Member
 
smerky's Avatar
 
Join Date: Sep 2012
Location: Kankakee, IL
Posts: 100
that looks great

smerky is offline  
post #10 of 10 (permalink) Old 04-23-2014, 12:19 AM
Junior Member
 
Join Date: Apr 2014
Posts: 4
Quote:
Originally Posted by jeff3254 View Post
Finally got my LED's installed to compliment the new sumo-x kit......& the new wheels.......... last pic,,,, had to brag on that new rear tire.... she looks soooooo much better with it on there.
Hey Jeff,

I just bought the Lizard Kit and the remote control... I have having the hardest time trying to figure out where the heck to mount the control box... Where did you mount yours and how has it held up? Also, I am thinking of mounting two under the tank on each side (4 total) and two under the rear fender. That leave me two left to mount and would like them to be behind the air filter if possible. Could you share you experience with this and add any pictures for me? I really could use your help (or anyone else who has done this and has some good advice!)
jwear21 is offline  
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Honda Fury Forums: Honda Chopper Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in









Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome