Honda Fury Forums: banner

1 - 11 of 11 Posts

·
Registered
Joined
·
183 Posts
Discussion Starter #1
The instructions that I got with the forward controls are retarded. They go into no detail of what needs to be removed and installed. Can anyone out there give a hand with some detailed instructions? Thanks!
 

·
Registered
Joined
·
183 Posts
Discussion Starter #5
Well, I put in a call to Captainfester and he walked me through the brake side and I ended up getting it done last night. What a pain in the ass! Wouldn't have been so hard if the instructions had some more detail and was illustrated. Anyway, now I get to take care of the clutch side. Hopefully that goes a little smoother.

Question: I have two thin washers that I can't seem to find where they go..Any ideas?
 

·
Registered
Joined
·
396 Posts
Well, I put in a call to Captainfester and he walked me through the brake side and I ended up getting it done last night. What a pain in the ass! Wouldn't have been so hard if the instructions had some more detail and was illustrated. Anyway, now I get to take care of the clutch side. Hopefully that goes a little smoother.

Question: I have two thin washers that I can't seem to find where they go..Any ideas?
If they are aluminum they are the banjo sealing washers for the brake hose.
 

·
Registered
Joined
·
183 Posts
Discussion Starter #8
Do they go on each side of the banjo fitting leading into the brake resevoir?
 

·
Registered
Joined
·
183 Posts
Discussion Starter #11 (Edited)
Well, I got the brake side all installed and everything works like a charm. I go to install the new clutch controls and find that the shift linkage has one side male threaded and the other female. This does not work too well when trying to connect the linkage to the actual clutch control because they are now both female. Sooooo..Now I have to call Accutronix and have them ship me a whole new part delaying my riding even longer. Just a heads up, maybe Accutronix should supply some sort of parts checklist when sending these controls. It'll make it that much easier to determine whether or not to start breaking the bike down. Hopefully I get a call back very soon and something overnighted to me. Talked to Troy and it looks like I am just missing the set screw on the other end. HE said I should be able to pick this up at the local hardware store....Looks like this problem has been fixed. Thanks Troy!
 
1 - 11 of 11 Posts
Top