Honda Fury Forums: banner

1 - 14 of 14 Posts

·
Registered
Joined
·
92 Posts
Discussion Starter #1
The cover around the ignition switch on my Fury vibrates like hell.

Sounds like a pack of angry bees going down the road.

Anyone had a similar experience and if so, how did you fix it.

Took it to the dealer and they said they could find nothing wrong. :confused:
 

·
Registered
Joined
·
500 Posts
I would think the dealer woulda found this, but have any of the little tools in your "toolkit" behind the ignition cover come loose and vibrate around? If it's the cover itself I dunno - there's just the 3 little plug thingies holding it in if I remember right; maybe one of them's not seated all the way?
 

·
Premium Member
Joined
·
6,195 Posts
Huh... first for me of hearing about this... make sure that your dealer put it together correctly and make sure the tabs are secured down?

Also, you sure it isn't your front engine cover, usually that's the case with a new bike... If this is the case, tighten down the allen screws and put a small amount of anti-lock on it to stop the engine vibration...

Last, if those two don't work, and Stonewheel's advice doesn't work, bring it to the dealer and explain to them what is wrong, they will fix it or replace it...
 

·
Registered
Joined
·
12,350 Posts
Mine has had a couple of different vibrations since I bought it. I figure whatever it is, it'll eventually fall off and problem solved.
 

·
Premium Member
Joined
·
6,195 Posts
Did this issue ever get fixed? If so, what was the issue?

You guys are funny btw... :p
 

·
Registered
Joined
·
122 Posts
He's not making it up, mine does the same thing and was even worse the last time I rode it, to the point where I was pushing on it with my hand just to shut it up. It's not loose, but I'm hoping this week I'll mess with it some and see what I come up with. If you find something that works let us know.
 
1 - 14 of 14 Posts
Top