Honda Fury Forums: banner

1 - 20 of 30 Posts

·
Registered
Joined
·
3,409 Posts
Discussion Starter #1
:D
FINALLY! Finally got to pick up my bike and ride today!
I had the sumo, 8's and a lot of other things done to my bike this LONG ASS WINTER!!
Let me start by saying with the sumo and 8 degree rake kit I really didn't see a difference in the way it handles. I think I am turning a little wider then normal. That could be because I havent ridden since November though. To me really no difference. My first turn I purposely turned the bike hard and took it way down! I figure I would just find out right off the bat if it was going to be a problem. Seemed normal.

So I have these LED'S (run turn brake) embedded in my sumo fender. They are encased in there own tube and epoxied in from the inside of the fender. In other words to get them out you need to pull the fender and take apart all the wiring and dig the led's out AND then reinstall all this crap if the lights ever went out.
So I'll give you a guess as to what is happening! THE F**CKIN LED'S ARE BURNING OUT ONE BY FU**IN ONE!!!. First two, then three, all they way to six of them now. And it's not the wiring or the led's coming loose. When the lights are off the ones burning out are darker then the ones that work. They are discolored. Dark spots on them.
These things are supposed to last for years! So what do I need to do! Everything I said above. But now I gotta send it to sumo to get it fixed!
I can't fuck**n stand it!
And for the record this is in no way Sumo's fault. It's the people who make the led strip. Kurt (sumo) was pretty pissed and is going to call them and see what the hell is going on. Now I gotta wait for days to ride again:mad: FUCKIN BEYOND FRUSTRATED!
One more thing. as for the thunder monster baffle. My cobra swept is twice as loud as it was before. I could never feel the exhaust before. Now I can threw the entire bike. LOUD AS HELL!
 

·
Registered
Joined
·
1,376 Posts
That sux dude ..... there is plenty of riding time left the season hasn't even started yet . Don't worry ... I just got my sumo fender today and started drilling holes for my LEDS gonna look bad ass ...
 

·
Premium Member
Joined
·
3,248 Posts
:D

So I have these LED'S (run turn brake) embedded in my sumo fender. They are encased in there own tube and epoxied in from the inside of the fender. In other words to get them out you need to pull the fender and take apart all the wiring and dig the led's out AND then reinstall all this crap if the lights ever went out.
So I'll give you a guess as to what is happening! THE F**CKIN LED'S ARE BURNING OUT ONE BY FU**IN ONE!!!. First two, then three, all they way to six of them now. And it's not the wiring or the led's coming loose. When the lights are off the ones burning out are darker then the ones that work. They are discolored. Dark spots on them.!
Are they supposed to be in the case ? or did they do this after to protect them, wonder if that has something to do with it. Just thinking out loud.:confused:
 

·
Registered
Joined
·
970 Posts
I was worried about ya had heard you pissed for a minute! :p Sucks on that kinda stuff for sure thats my luck had a ZX6r that I put a rear tail on with leds and the same thing happened. The baffles are killer finally sounds like a real bike I love mine.
 

·
Registered
Joined
·
3,348 Posts
Sounds like bad resistor, no resistor, LEDs getting to much current, or someone reversed the lead, or they can be destroyed by high heat, soldering. I ain't saying anything else, I know whats good for me! :D

PS Sure hope while you are out tonight someone doesn't ask you, hay Bud, got a Light?
 

·
Registered
Joined
·
788 Posts
[PS Sure hope while you are out tonight someone doesn't ask you, hay Bud, got a Light?[/QUOTE]

Mental, you're just not right man!!!!!:D:D:D
 

·
Registered
Joined
·
1,312 Posts
I assume the strip is made from Radiantz............their strips are absolute shit. I've been through four of them on my RAW taillight and I'm finally done and going for something different. The same thing happens every time....just like you described. I hate it
 

·
Premium Member
Joined
·
6,731 Posts
What was that old song they used to sing on Hee Haw? “If it weren’t for bad luck, I’d have no luck at all”

Kurt will take care of ya!
 

·
Premium Member
Joined
·
3,454 Posts
it does sound like a voltage issue and/or crappy product. the vendor needs to cover shpg and kurt could add a load equalizer.
definitely find another LED vendor.
 

·
Premium Member
Joined
·
5,764 Posts
First and foremost - Do you have a guardian bell on your bike? If not, I am going to buy one and send it to you. You get stuck with some serious sh!t luck :(

One more thing. as for the thunder monster baffle. My cobra swept is twice as loud as it was before. I could never feel the exhaust before. Now I can threw the entire bike. LOUD AS HELL!
"Twice as loud" ... Is that in comparison to the Cobra's sound w/ or w/o baffles??
 

·
Premium Member
Joined
·
5,764 Posts
mrbyber.....I gotta tell ya.....I wouldn't go to the casino's with ya....:eek:
Bob, you got it backwards. He IS the one to follow at the casino. Just sit at the slot machine he walks away from after hours and Cha-Ching! :p
 

·
Premium Member
Joined
·
5,764 Posts
I assume the strip is made from Radiantz............their strips are absolute shit.
OK, now you've got me concerned because my light from L&M with my new fender is a Radiantz product.

So, did you get another strip from someone else of the same design? If so, from whom?

I'm going to look into buying a spare, now, just in case. I'll not be sitting on my hands if/when my Radiantz start to blow.
 

·
Premium Member
Joined
·
13,706 Posts
sounds like another strip gone bad.i have replaced two on one bike in a week.
 

·
Premium Member
Joined
·
6,195 Posts
Sorry bout the LED's, I semi went through a similar issue, but it was only after I had been riding through a lot of rain... If it is Radiantz, they are good about warranty's, so you should get some new one's. Make sure to tell Sumo, once he shapes them, to add some silicon behind them as well. When you heat them up to shape them, they sometimes will develop small crack on the back side of them, cause by over-heating them or by the plastic deforming a little bit on the back side... Just a heads up.

Personally, it sounds like an internal wiring issue inside the LED's, as I bet this fender hasn't been out in the rain.

**Wonder if that baffle would fit into my pipes? Curious about the sound now... hmmm, have a link?
 
1 - 20 of 30 Posts
Top