Honda Fury Forums: banner

1 - 3 of 3 Posts

·
Registered
Joined
·
1,152 Posts
Discussion Starter #1
I was riding last night and I noticed that my front running lights weren't on so I pulled into a parking lot and sure enough both front run/turn lights were not working. It is just both front light and both back lights still work fine so I figured it was a wire or a fuse or something. I took the headlight apart today and found the fuses on the bike to diagnose the problem, there is not a separate fuse for the front run/turn lights so I started looking at wires. All of the wires looked perfectly fine so the test light came out and I have power all the way to the little board inside the turn signal. Has anyone had problems with the silver bullets going out? I am going to call Kury Monday and see if I can get them replaced under warranty since they are less then a month old. I did look on Kury's website and they are about to release a super bright version of the lights that looks like they use the CREE small square LEDs so that will probably be a upgrade for mine when I get them working.
 

·
Premium Member
Joined
·
6,195 Posts
I was riding last night and I noticed that my front running lights weren't on so I pulled into a parking lot and sure enough both front run/turn lights were not working. It is just both front light and both back lights still work fine so I figured it was a wire or a fuse or something. I took the headlight apart today and found the fuses on the bike to diagnose the problem, there is not a separate fuse for the front run/turn lights so I started looking at wires. All of the wires looked perfectly fine so the test light came out and I have power all the way to the little board inside the turn signal. Has anyone had problems with the silver bullets going out? I am going to call Kury Monday and see if I can get them replaced under warranty since they are less then a month old. I did look on Kury's website and they are about to release a super bright version of the lights that looks like they use the CREE small square LEDs so that will probably be a upgrade for mine when I get them working.
Hook it up old skool style first before you call them... grab some wires, put them into where the existing wires are now... If you wired it up, it is probably easy to get to the wires that you hooked up or you can figure out an easy bypass to simply get to the wires for the new light's. Disconnect the lights and hook up that wire, then plug into the lights and see what you get... Figuring you're not a fool, so you will either get something or you will not... get back with us with the findings... oh, BTW.. a simple 1/4 slice into your heat-shrink or whatever should do you fine, then stick the wire in there... if they work after that, that means you hooked up your original wiring wrong... back to drinking and I am curious as to what you find out... peace out for PI love... :D
 
1 - 3 of 3 Posts
Top