Honda Fury Forums: banner

1 - 17 of 17 Posts

·
Premium Member
Joined
·
5,715 Posts
Discussion Starter #1
I got the Kuryakyn deep dish turn signal covers (smoked) and put them on over the weekend. Have a couple of questions.....I put the amber bulbs in and on the front two, when in running mode, both filaments are lit up.....but when the signal is on, only one filament lights up - looks pretty dim....is that normal?

Second, the heat shield on the rear signals seems to bind on the square metal cover on the inside (nearest the bike) of the turn signal lense, such that when I put the covers/lenses on, they wouldn't quite seat on the side near the bike.....did anyone else have that problem? Looks to me like the kury heat shield would have to be cut out a little.......any info would be appreciated.

Thanks,
Bob
 

·
Premium Member
Joined
·
1,970 Posts
I got the Kuryakyn deep dish turn signal covers (smoked) and put them on over the weekend. Have a couple of questions.....I put the amber bulbs in and on the front two, when in running mode, both filaments are lit up.....but when the signal is on, only one filament lights up - looks pretty dim....is that normal?

Second, the heat shield on the rear signals seems to bind on the square metal cover on the inside (nearest the bike) of the turn signal lense, such that when I put the covers/lenses on, they wouldn't quite seat on the side near the bike.....did anyone else have that problem? Looks to me like the kury heat shield would have to be cut out a little.......any info would be appreciated.

Thanks,
Bob
Bob:
The bulbs in front are in wrong, I had this problem with one of my bulbs. The Honda 1157 sockets tend to allow the bulb to defy the high versus low tab of the bulbs. So the result is bright element is running and the low element is on when blinking.
I don't think the directions indicate to reuse the metal tab off the old lens for the screw, but you probably figured that out.

As far as the rear shields, they are tricky to seat properly. Patience is needed..

Hope that helps..
 

·
Premium Member
Joined
·
5,715 Posts
Discussion Starter #3
Bob:
The bulbs in front are in wrong, I had this problem with one of my bulbs. The Honda 1157 sockets tend to allow the bulb to defy the high versus low tab of the bulbs. So the result is bright element is running and the low element is on when blinking.
I don't think the directions indicate to reuse the metal tab off the old lens for the screw, but you probably figured that out.

As far as the rear shields, they are tricky to seat properly. Patience is needed..

Hope that helps..
Tony,

So I use the same bulbs but just put them in with the higher tab at the top?

The directions did indicate using the old metal screw tab, which I did do...I did take out the old heat shields....but the kury ones don't seem to be deep enough on the side near the bike and hit that metal square shield on the stock signal housing....there is about a 1/16th gap between the part of the new lense that you can see from the side and the old housing....about a thumbnail width......I don't want water getting in there...not sure if it would, but would like them to seat properly....I messed around with trying to seat them for over a half hour - even switched the kury heat shields on different signals to see if that made a difference, and it didn't......
 

·
Premium Member
Joined
·
1,970 Posts
same bulbs, just reverse inserting them.

I only see the smoke lens between the new cover and the mounting socket.
I know there is a top cut out tab that has to be aligned with cover.
You kind of get the top snapped in first.
I made sure the shield was inserted first before putting on the cover.
Not certain why you have a gap unless it is cocked. You do have to kind snap the cover on the bottom after getting it under the top notch.
 

·
Premium Member
Joined
·
5,715 Posts
Discussion Starter #5
Thanks Tony,

I'll reverse them when I get home....guess I'll have to live with the gap between the socket and the lense until I figure out what to do about it....I got the screws lined up and snapped the bottom as you did....it just seems that the heat shield isn't quite formed right.....I'll mess with it.....

Sure do appreciate your help Tony,
Bob
 

·
Registered
Joined
·
1,157 Posts
i just put mine on the other day,,had no issues with them at all,,as far as there being a binding,, I put the top in first then used just a tad of vaseline on the bottom and they slid right in,,there seemed to be some suction force pushing the covers out not to allow the screws to line up but i just used some good ole elbow grease and they went in,,I used the screw caps that slid over the plastic tab,,the packages were marked on the amber ,,front left,,front right, and i did red in the back.
 

·
Registered
Joined
·
358 Posts
I have front and rear for sale, I'll send the complete stock light with the Kury deep bezels (smoked), mount has been cut. Anyone interested. $50 plus shipping. I went with mini bullets front and rear
 

·
Registered
Joined
·
248 Posts
I got the Kuryakyn deep dish turn signal covers (smoked) and put them on over the weekend. Have a couple of questions.....I put the amber bulbs in and on the front two, when in running mode, both filaments are lit up.....but when the signal is on, only one filament lights up - looks pretty dim....is that normal?

Second, the heat shield on the rear signals seems to bind on the square metal cover on the inside (nearest the bike) of the turn signal lense, such that when I put the covers/lenses on, they wouldn't quite seat on the side near the bike.....did anyone else have that problem? Looks to me like the kury heat shield would have to be cut out a little.......any info would be appreciated

Thanks,
Bob
heyy does anyone have pictures of those covers on a fury?
 

·
Registered
Joined
·
193 Posts
Gary, I'll buy them. Send me your address and I'll mail a check to you today. My address is;
7201 Goldenrod Circle
Wausau, WI 54401

Please indicate shipping charge and when they are mailed. Thx
 
1 - 17 of 17 Posts
Top