Honda Fury Forums: banner

1 - 8 of 8 Posts

·
Registered
Joined
·
784 Posts
Discussion Starter #1
I have just finnished installing a set of engine covers to my Fury & I have to agree with Redspawnsilver that the bolts are not good spec.
I was fitting the last part on the right hand side.when the single bolt locked itself up.I was able to free it with some WD & replaced the the cross threaded bolt with a conventional allen bolt with a chrome dot stuck in the top.
These sets are not cheap over here in Britian,having said that I still like the look of them they really do make the motor stand out...:cool:
 

·
Registered
Joined
·
427 Posts
Man mine did the same thing.. What is up with that? I was not happy, like you said the covers are not cheap..
 

·
Registered
Joined
·
427 Posts
Just the last bolt on the right side, the last piece that is installed on the bottom.
 

·
Registered
Joined
·
784 Posts
Discussion Starter #6
So the bolts are going in halfway and cross threading? Or is it just on the last bolt on the right side?:confused:
There are 3 bolts in the kit.2 are used in the tube supporting the left & right sides [between the lower V on the motor] the 3rd is used on the small plate that fits between the covers on the right hand side,the problem seems to be that the bolt threads are to soft.The bolts in the tube installed O K but the one on the in the plate tore off its thread.I replaced it with a cadmium allen bolt which installed with no problem.
 

·
Registered
Joined
·
230 Posts
i wonder what it would look like if you painted the engine covers black... or if they would make some in black...
 
1 - 8 of 8 Posts
Top