Honda Fury Forums: banner

1 - 7 of 7 Posts

·
Registered
Joined
·
6 Posts
Discussion Starter #1
I installed an aftermarket cruise control on the bike. All it's a clamp on cruise control. Since i installed it my turn signals fuse keeps on popping and i have to replace it right away. Is there anything that would cause my fuse to pop.
 

·
Premium Member
Joined
·
6,195 Posts
One of your wires is probably grounded somewhere... QQ, is it blowing without you using the horn? If so, that probably means that one of your wires is hooked up wrong, go back over the instructions again and take your time. Might just have to unhook everything for now and rehook everything when you have the time.
 

·
Premium Member
Joined
·
4,751 Posts
Is it a Vista Cruise Control? I might be confused but he said he installed a clamp on cruise control so if that's the case I don't see how he could be popping a fuse, maybe I'm missing something.
 

·
Premium Member
Joined
·
2,560 Posts
Your horn, brake and turnsignals are all on the same fuse. If they are still stock you have a shorted + wire on one of those circuits. It narrows down if the fuse blows only when you use one of those functions. Time for a shop manual or a Honda mechanic ;).
+1
You probably pinched the brake light wires when you installed the throttle lock, take it back off and check the 2 black wires that plug into the switch.
 

·
Premium Member
Joined
·
13,703 Posts
+1
You probably pinched the brake light wires when you installed the throttle lock, take it back off and check the 2 black wires that plug into the switch.
what clueless said.clamp got the brakelite wire.
 

·
Premium Member
Joined
·
3,454 Posts
+1
You probably pinched the brake light wires when you installed the throttle lock, take it back off and check the 2 black wires that plug into the switch.
what he said...
 
1 - 7 of 7 Posts
Top