Honda Fury Forums: banner
1 - 20 of 21 Posts

·
Registered
Joined
·
17 Posts
Discussion Starter · #1 ·
Ok guys, got the Viper II's and Fuggin EFI controller in today and just finished the install which was as easy as it gets. Took just over an hour and a half, not counting the time I had to go get a 45 degree socket from a buddy. Took the bike for a spin and I got some backfiring going on upon deceleration.....I thought maybe everything just needed to get settled in so I took it for about a half hour ride and it's still doing it.
 

·
Registered
Joined
·
17 Posts
Discussion Starter · #2 ·
VIPER II's and Backfire

Just installed the Viper II's and the Fuggin EFI. Took a spin and I got some backfiring going on... Does it just need to settle in until everything makes friends or is something out of adjustment. Sposed to be plug and play and set up from Fuggin for factory breather..... Anyone know ....
 

·
Premium Member
Joined
·
1,992 Posts
What do you mean, backfiring? WOT, on decel?? Did you follow the instructions for the fuel controller install?

EDIT: I just merged your threads, you started 2 different posts. As for the decel, I couldn't tell you what's going on. I only experienced it when my bike was on the dyno (before it was tuned). Maybe the Fuel Controller isn't hooked up correctly.
 

·
Registered
Joined
·
17 Posts
Discussion Starter · #4 ·
Yep even called up Doug to make sure there was no difference between the front and rear connections to the injectors. It's on decel..... Just sent you a private ... Sorry...
 

·
Premium Member
Joined
·
1,992 Posts
Hmm... I know you have slight adjustability for the fuel.

Are you going from a high rev to completely letting off the throttle and engine braking. I don't know what to tell ya :confused:
 

·
Registered
Joined
·
140 Posts
Sucks to hear ya going through mod pains, hang in there, you'll get it whipped. I am personally leaning towards Cobra pipes and fuel manager , just from previous cobra products giving me ZERO issues. Not knockin your decision, should be bitchin when ya get it dialed in.
 

·
Registered
Joined
·
17 Posts
Discussion Starter · #7 ·
Yes completely letting off the throttle and during downshift ..... Like I said, nothing crazy just a nice pop and nice blue flame I called Doug back but they already closed up shop ???????....
 

·
Registered
Joined
·
17 Posts
Discussion Starter · #8 ·
Predator it's that exact same thing now that you mentioned it. When yours was on the dyno.
 

·
Registered
Joined
·
111 Posts
Backfiring on Decel

Stranger, I just put mine on tonight and found that I have the backfiring issue too and I'm using the Fuggin Fuel Programmer. I'm waiting on the back ordered Air Kit from Fuggin to so maybe that could be the problem? Any help Doug, Predator or anyone out there on this issue would be great. BTW both lights on the left side of the programmer are on solid green...:confused:
 

·
Registered
Joined
·
829 Posts
Cobras without baffels do this too!

My Cobras without baffels do this too even with PCV and getting professionally tunned. I am not sure how much this hurts your enginee (or if it does) but I do not see this as a huge issue. The only time it does this is if I try to decel too quickly.
 

·
Premium Member
Joined
·
1,967 Posts
Stranger, I just put mine on tonight and found that I have the backfiring issue too and I'm using the Fuggin Fuel Programmer. I'm waiting on the back ordered Air Kit from Fuggin to so maybe that could be the problem? Any help Doug, Predator or anyone out there on this issue would be great. BTW both lights on the left side of the programmer are on solid green...:confused:
FYI:
I do not have the Viper pipes and mine backfires once in a while upon decel.
When I first installed the Fuggin fuel controller I only had the S & S air cleaner with the stock mufflers and it did it, it just wasn't as noticeable with the mufflers. When I changed the pipes it was more noticeable.
I tested with the fuel controller disconnected it it did the same with the new pipes. I have the baffles in.
I haven't noticed any flames coming out of the pipes, but I was not looking at it while decelerating. I will check this out at night.

The fuel controller does show two green led's when idling and increases to four to five led's when the throttle is increased.

I have the CALIFORNIA Type Fury and have not removed the PAIR system.
 

·
Premium Member
Joined
·
1,992 Posts
I know on a high RMP decel, it is common for slight backfiring. I've had it happen on cars and motorcycles in the past. I haven't experienced it on the Fury since it was tuned in, however, I've only riden it one day since then :(

For a better answer, you can always try to call a tuning shop :confused: I know I am no help behind this computer ;)
 

·
Registered
Joined
·
314 Posts
This thread is getting me nervous. I have the viper2s on order and the fuel controller. I'm a noob to this mod scene, but I thought if I followed directions, installed the fuel controller and did everything the way it should be done without cutting corners, I would eliminate any funky problems that might arise. Backfire being a big one, I like the fury stock. It's a sharp bike. I don't need mods at the expense of my bike going ghetto on me! I hope this is just a freak issue and nothing serious. As far as Predators post, I can deal with slight backfiring, not a big deal. It's the "HOLY CRAP WHAT WAS THAT?!?!" Backfiring I don't want.
 

·
Registered
Joined
·
127 Posts
Backfiring on Deleration

I understand that some of you may have some backfiring on deceleration with the Fuggin fuel controller.
The first thing to do is check for leaks at our exhaust ports. If you did not change the gaskets and the exhaust is not seated right, the bike will backfire. Check or replace the gaskets. Also it is recommended that you re-tighten the exhaust port nuts after 8 to 10 hours of riding. When things go from hot to cold they tend to loosen up.

If you have not changed your air-filter and or you are living close to sea level you may also be experiencing this problem. The bike is not getting the fuel it needs at idle and you need to make a small adjustment on the controller. Please follow the operating instructions to adjust the green mode and bump up (+) the fuel one time.

If you would like details on how to make this adjustment please send me an email and I will forward the information.

[email protected]
 

·
Registered
Joined
·
114 Posts
There you go. Doug just took the words right out of my mouth. I noticed Stranger mentioned he had the STOCK air cleaner, with the new Fuggin pipes. The Fuggin fuel controller to my knowledge is preset for their pipes WITH the addition of a cone style air filter with increased flow.

Just my 2 cents....
 

·
Registered
Joined
·
314 Posts
I've to be honest.. Doug does a good job of keeping me from jumping off ledges through explanation and education.

As I said earlier, I'm a newbie and neurotic.. I'm watching to see how Stranger's problems work out.
 

·
Registered
Joined
·
17 Posts
Discussion Starter · #17 ·
Figured it out ....... My bad ... You should always replace the exhaust gaskets with new pipes and I didn't... I called Doug at Fuggin and he guessed it right off. I stopped by the Honda dealership and picked up two new "smash" gaskets, dropped the exhaust off and remounted it. No backfire at all and man do these pipes sound good. Hats off to Fuggin and the Viper II's great job guys. And Doug gets the customers service award ....
 

·
Premium Member
Joined
·
1,992 Posts
I'm glad you found the fix... I just knew it wasn't the pipes or the fuel controller because my stuff turned out great ;)
 

·
Registered
Joined
·
1,120 Posts
Mine pops a bit when letting off from WOT. I am going to get some new gaskets from Honda and stack them over the old ones. This is one suggestion that the tech from Fuggin Fab had.
 
1 - 20 of 21 Posts
Top